欢迎光临
一起学习,一起进步

python ubuntu

Ubuntu16.04下安装python、pip、PyDev


【参考1:ubuntu下python版本切换】(http://duanhq.leanote.com/post/ubuntu%E4%B8%AD%E5%88%87%E6%8D%A2python%E7%89%88%E6%9C%AC)
【参考2:update-alternatives工具使用简介】(http://man.chinaunix.net/linux/debian/debian_learning/ch08s21.html
【参考3:ubuntu下安装python】(http://blog.csdn.net/qq_27657429/article/details/53482595)
【参考4:更新python版本后如何安装pip】(https://support.snowflake.net/hc/en-us/articles/208659926-Error-Traceback-most-recent-call-last-File-usr-bin-pip-ImportError-No-module-named-pkg-resources-when-installing-the-Snowflake-Connector-for-Python)
【参考5:apt安装python相关库时出现apt_error问题解决方法】()
【资料1:get-pip.py下载地址】(http://pip.readthedocs.io/en/stable/installing/)
【资料2:JAVA下载地址】(https://www.java.com/en/download/linux_manual.jsp)
【资料3:Eclipse下载地址】(https://www.eclipse.org/downloads/)

1.添加源并更新:

sudo add-apt-repository ppa:fkrull/deadsnakes
sudo apt-get update

2.安装指定版本的python,这地方可以更改成你需要的版本(3.6 3.5 ….):

sudo apt-get install python3.6 python3.6-dev
安装32位库
sudo apt-get install libncurses5-dev
 
或者使用python运行 get_pip.py程序即可

3.切换python版本:

安装好后会在 /usr/bin/ 下出现 python3.6 这个可执行文件,现在需要切换版本(默认版本2.7)
如下就是设置python3.6的路径,并设置优先级为200,默认优先级最高的优先使用
sudo update-alternatives --install /usr/bin/python python /usr/bin/python3.6 200
所以如果想要使用系统默认的2.7版本,需要键入 sudo update-alternatives –install /usr/bin/python python /usr/bin/python2.7 250 并设置优先级大于其他的版本
注:首次必须使用上述命令进行添加才能用下面的命令查看
使用 sudo update-alternatives --config python 可以查看所有已添加的python程序路径和优先级,同时可以更改使用哪个python版本
特别注意: 有些ubuntu下的软件依赖原生的python即python2.7,如果执行apt-get -f install 自动安装依赖时因为python版本不同可能导致出现如 E: Sub-process /usr/bin/dpkg returned an error code (1) 的错误,可以通过先将python版本切回2.7在执行apt-get -f install 基本上都能解决
网上还有通过ln软连接来设置python,一定要注意如果使用ln方法首先备份原始文件,当然这里不推荐使用这种方式

4.安装pip

这个时候终端键入pip会出错,因为我们没有安装当前python版本对应的pip,所以需要更新pip
【资料1】 下载 get-pip.py 文件
然后进入文件下载的地址
注:这时的python版本应该已经是你所需要的版本了(本文是3.6版本)
终端键入 sudo python get-pip.py 自动下载pip,安装好pip后,终端键入 pip -V 查看 是否正确指向python3.6包的路径并且结尾是否是python3.6 ,无误后就可以安装其他包什么的了
当然,如果切换回python2.7也要运行安装pip的命令

5.安装PyDev

首先强调权限问题,安装程序使用root权限会导致普通用户下无法运行eclipse,所以下面都是用普通用户权限进行操作的
【资料2】 下载对应系统带宽(32bit or 64bit)的Java-JDK
这里我下载了jre1.8.0_121版本,解压缩到当前文件夹下
【资料3】 下载对应系统带宽(32bit or 64bit)的eclipse
这里下载了eclipse-neno版本,注意一定要选择离你最近位置的mirror,否则会安装出错,解压缩到当前文件夹下
将刚才解压的jre1.8.0_121文件夹拷贝到eclipse解压的目录下,改名为jre,然后双击eclipse-inst或终端普通用户下键入 ./eclipse-inst 运行安装程序
1. 点击第一个for java版本的eclipse,路径选择在/opt( 如果普通用户没有opt写权限则不能安装,可以先chown 更改 opt 的所有者 ),然后点击INSTALL安装,中间弹出是否接受许可,这里点Accept,然后安装需要一段时间,看网速
2. 安装好后点击LAUNCH运行,选择你的工作目录,这时可以右击启动器锁定到启动器来创建快捷方式
3. 进入界面关掉Welcome界面,点击菜单栏的 Help->Install New Software ,出现界面点击右侧的Add,Name一栏我们填写 PyDev ,Location一栏我们添加上 dl.bintray.com/fabioz/pydev/5.5.0 (过去使用的是www.pydev.org/updates,现在不能用了),点击 OK,出现两栏,勾选第一个 PyDev ,点击Next,再点击Next,勾选I accept the……. 然后点击Finish进行下载安装
4. 中途会出现安全警告,点击OK,接着弹出窗口,选择Select All,点击OK,然后要求重启eclipse,点击Yes

7.配置PyDev环境并测试

在eclipse界面下点击菜单栏File -> New -> Project,选择PyDev的PyDev Project点击Next,弹出窗口,首先需要配置Python,点击Please configure an interpreter before proceeding,可以手动配置也可以自动配置,这里我选择手动,点击右上角的New,Name填入Python3.6,下面一栏填写路径,我直接指向 /usr/bin/python3.6 ,然后点击OK,弹出窗口选择Select All,点击OK,然后再点击右下角的OK即可。
回到工程创建目录,我们Name填入test,Grammar Version选择3.6,然后点击Finish,第一次建工程会弹出一个框,提示你会进入PyDev环境,这里勾选Remember my decision并点击Yes
右击工程new一个PyDev Module,名字填写test,点击Finish,第一次新建模块会出现弹窗,点击Ok,然后另一个弹窗选择Empty文件,点击Ok
键入 print(“Hello Python”)
Ctrl + F11 点击OK运行,成功输出
注:有人会遇到新建的空白文件键入print(“Hello Python”)都运行失败,这可能是编码问题,更改编码或者更改系统语言为英语都可以解决

赞(0) 打赏
未经允许不得转载:openSL » python ubuntu

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏